®

sponsored by

Your Photoshop is in My After Effects
With RICHARD HARRINGTON
Richard Harrington is a certified Project Management Professional, Adobe Certified Expert and Instructor in
Photoshop and After Effects, and Apple-certified instructor in Final Cut Pro and Motion. Additionally, he has
completed Avid’s Master Editor Workshop and the Avid Certified Instructor Program.
His visual communications company, RHED Pixel, creates motion graphics and produces video and multimedia
projects. He is a faculty member at The Art Institute of Washington, a popular speaker at conferences, and an
instructor for Future Media Concepts. He is the author of Photoshop CS for Nonlinear Editors and as well as a
moderator Creative Cow’s Photoshop and Motion Forums.
Be sure to check out Rich’s websites for more resources:
• Raster|Vector Blog: http://www.rastervector.com
• Photoshop for Video: http://www.photoshopforvideo.com
• RHED Pixel: http://www.RHEDPixel.com
• Motion Control 3D: http://www.motioncontrol3D.com

It’s Like Photoshop... With a Timeline

notes

After Effects is an incerdibly deep and elaborate program. This means it will take a (long) while to
master. Fortunately there are many similarities between Photoshop and After Effects. Learning
this similarities will make the program easier to use.

Mastering AE’s interface
So you want to be fast? Don’t think of After Effects as a tool; think of it as a creative extension.
Over time, you’ll gain confidence with all the controls. You want to be able to make the interface
“disappear,” which will allow you to reach “inside” the computer and create. Great designers know
that the more brainpower they can put toward their graphics (not graphic system), the better the
results. Although learning an interface may not be as “fun” or “sexy” as a good effect, it’s infinitely
more important. Don’t skimp on learning AE’s interface.
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Get Your Toolbox Out
Need access to your tools? To change tools on the fly try these shortcuts:
V
Selection Tool
W
Rotation Tool
C
Toggles between Orbit Camera, Track XY Camera and Track Z Camera Tools
H
Hand Tool
Z
Zoom Tool
Y
Pan Behind Tool (Also works as Trim)
Cmd+B/Ctrl+B Cycles between Brush, Clone Stamp, and Eraser Tools
Q
Cycles between Rectangular and Elliptical Mask Tool
Cmd+T/Ctrl+T Cycles between Horizontal and Vertical Type Tools
G
Cycles between Pen, Add Vertex, Delete Vertex and Convert Vertex Tools

A Working Canvas
By default, After Effects presents you with a black background in the comp window. While this
is often useful, it may not work in all situations. Sometimes a contrasting background color may
be needed when adjusting shadows or dark tones. Choose Composition>Background Color or
press Cmd+Shift+B (Ctrl+Shift+B) to pick a new color. This
color is temporary, and is not included in the render. It will
be replaced with black when the comp is rendered.
If you are a Photoshop user, you might be more comfortable working with a transparency grid instead of a
colored background. In the submenu of the Composition
window, choose Transparency Grid to set the comp window to transparent. When you render the file, After Effects
will fill the transparency with black.

Opening Your Tool Chest
There are several palettes in After Effects, more than you’ll usually want to deal with at once. To
access the palettes, go to the Window menu or press the following shortcuts.
Cmd/Ctrl 1	
Cmd/Ctrl 2	
Cmd/Ctrl 3
Cmd/Ctrl 4
Cmd/Ctrl 5
Cmd/Ctrl 6
Cmd/Ctrl 7
Cmd/Ctrl 8
Cmd/Ctrl 9

Show/Hide Tools
Show/Hide Info
Show/Hide Time Panel
Show/Hide Audio
Show/Hide Effects Palette
Show/Hide Character Palette
Show/Hide Paragraph Palette
Show/Hide Paint Palette
Show/Hide Brush Palette
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Grids
Grids can be useful when laying out your design
freehand. To turn grids on, choose View>Grid or press
Cmd+’ [Single Quote] (Ctrl+’). Even more useful is the
ability to turn on Snapping to the grid by pressing
Cmd+Shift+’ [Single Quote] (Ctrl+Shift+’). To adjust
grid options, go to the preference menu and set frequency.

Using Rulers
Rulers are useful for checking the position of elements in your composition. Choose View>Show Rulers
or Press Cmd+R (Ctrl+R) to bring them out. Once they’re
out, rulers can unlock a lot of useful features.
• You can adjust the rulers’ center point by clicking in
the upper left corner of the Comp window. Click and
drag to reposition the rulers.
• You can drag guides from the rulers for use in your
composition.
• You can turn Snapping on for guides, by pressing
Cmd+Shift+; [semicolon] (Ctrl+Shift+;).
• To toggle guide visibility, press Cmd+; [semicolon]
(Ctrl+;).
To lock guides in place, press Cmd+Option+Shift+; [semicolon] (Ctrl+Alt+Shift+;).

Get a Hand on Things
Need to pan around the comp window or timeline?
Activate the hand tool by pressing the spacebar. This is a
temporary switch. Adjust the viewed portion on the timeline
or comp window, then release the spacebar

I need Shades…
Most compositing Applications, such as Shake
and Combustion, ship with the interface set to
50% gray. This makes it easier to make complex
judgments about color and contras. After Effects
6.5 now gives you the ability to adjust the brightness of windows and palette backgrounds
Step 1: Choose Adobe After Effects >
Preferences > User Interface Colors (Edit >
Preferences > User Interface)
Step 2: Adjust the User Interface Brightness
slider to adjust brightness.

notes
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Change the Channel
When doing complex effects or color correction, it is often important to check the channel view of your footage. You can do this
by clicking on the small strips of red, green,
blue, or white (for the alpha) at the bottom
of the comp window. These views can also
be toggled from the keyboard. Press the
following keys to switch between channel
views:
• To show the red channel, press Option+1
(Alt+1).
• To show the green channel, press
Option+2 (Alt+2).
• To show the blue channel, press Option+3
(Alt+3).
• To show the alpha channel, press Option+4 (Alt+4).
To toggle back, press the same keyboard shortcut again.

Reality Show
If you view your comp window at a custom size, you may have redraw errors. Simply put, the
computer is a lot better at showing you what 100 percent (or 50 percent or 200 percent) looks like
than say 63.27 percent. Computers are efficient at dividing or multiplying by two. If you are doing
detail work such as keying, glows, or particles, you’ll want your Comp Window’s magnification to
be 100 percent. To quickly zoom in, try the following shortcuts in the Comp window:
• To zoom 100 Percent, press / [forward slash].
• To zoom 100 Percent and resize the Comp window, press Option+/ [forward slash] (Alt+/).

Speeding up the
Comp Window
Lowering the resolution of the Comp
window can dramatically speed up previews. For example, switching from Full
Resolution to Half Resolution speeds up
previews four times (as it reduces both the
width and height in half ). In fact, previewing at half quality with the comp window
set to 50 percent often provides a perfectly
acceptable preview. To switch preview resolution quickly, use the following shortcuts.
• For Full Resolution, press Cmd+J (Ctrl+J).
• For Half Resolution, press Cmd+Shift+J (Ctrl+Shift+J).
• For Quarter Resolution, press Cmd+Option+Shift+J (Ctrl+Alt+Shift+J).
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Clean Up Your Workspace
Have a few too many toolboxes open? Don’t worry. You can quickly hide all floating toolboxes by
pressing the Tab key. If you’d like to get rid of all floaters except the Tools palette, press Shift+Tab.
This shortcut works in most other Adobe applications as well.

Clean Your Room
Looking for a fast way to get your windows
back in shape? Maybe you’ve lost a window
off-screen as well? Not a problem… simply
choose Window>Workspace>One Comp view
to return to the default layout.

Build Your Own Room
You’ve configured your windows perfectly.
Every palette and the time controls are exactly
where you want them. The timeline has just
enough room. Now save that window arrangement.
Step 1:. Choose Window>Workspace> Save
Workspace.
Step 2:. Name the workspace and click OK.
Step 3:. It now appears at the top of your
Workspace list.
Step 4:. After modifying a workspace, save it
again with the identical name, and when prompted, choose Yes to overwrite the old workspace.
Step 5:. Workspaces are saved in, and become part of your user settings when you quit After
Effects.
To delete a workspace choose Window>Workspace>Delete Workspace.

I Lost My Effect
Those darn Effects categories! Where is Change Color, anyway? Adjust, Image Control? Stylize?
Next time you’re searching for an effect, don’t click the Effect Menu and search through the categories. Instead, choose Window>Effects, or press Cmd+5 (Ctrl+5). A handy effects search engine
will pop up.
In the text box at the top, start to type the name of the effect you want. If you type D, the window will list all effect names that contain the letter D. If you type Displace, the window will list
Displacement Map, Turbulent Displace and Time Displacement. To apply an effect to the selected
layer, double-click its name. Or, drag the effect from the Effect window and drop it on any layer in
the Timeline or Comp Window.

notes
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A Bigger Preview
Want to take your RAM previews full screen? By
clicking the Full Screen box in the Time Controls
palette, After Effects will do just that. When the
RAM Preview is started, the screen goes black and
the preview is loaded. Press the spacebar to start
the preview mid-load. To exit, press the ESC key.

A Smaller Preview
Wouldn’t it be nice to focus only on what you care about? You can do just that in the AE world.
Why preview the entire comp window when it is much faster to look only at the part of your composition that interests you. Here’s how.
Step 1:. Enable the Region of Interest by clicking on
the small icon next to the resolution menu in the comp
window.
Step 2:. Drag out the area you’d like to see.
Step 3:.When starting a preview, only the highlighted
area is seen.
Step 4:.To exit, click on the Region of Interest icon
again.
Step 5:. Using Region of Interest has no impact on
your rendered file.

A Longer Preview
Using a RAM preview in After Effects is great as it’s a quick way to preview your work. Great that
is until you run out of RAM! In After Effects
6, when you run out of RAM, AE must purge
frames from the buffer.
After Effects 6.5 changes this though and
helps speed up your workflow. Now when the
RAM cache gets full, frames are cached to your
hard drive. Don’t worry though, you can set
a cache limit and the cache is emptied when
you quit AE.
To set up disk caching:
Step 1:. Choose After Effects>Preferences>Memory & Cache (Edit>Preferences>Memory &
Cache)
Step 2:. Check the checkbox to Enable Disk Cache.
Step 3:. The Choose Folder dialog box automatically opens and you need to specify where to
write the cache. For best results place the frames on a local drive, but if possible, not the same
drive as your source footage.
Step 4:. Specify an amount for Maximum Disk Cache Size in megabytes (the default is 2000 MB.)
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Send it Out
Mac users previously had the ability to preview their AE comps over Firewire or a video card, starting with the release of AE 6.5, PC users can too! Plus Adobe has enhanced the ability of the preview all around. It is possible to preview the contents of a Layer, Footage, or Composition window
on an external video monitor.
You can set Video Preview preferences
by choosing After Effects > Preferences
>Video Preview (Edit > Preferences >
Video Preview). Choose one or more of
the following interaction types.
Previews: Both RAM preview and standard (spacebar) preview load on the
external monitor. Choose Mirror on
Computer Monitor to if you want to see
the preview simultaneously on the computer screen and the external monitor,
however mirroring reduces performance.
Interactions: Interactive previews such as scrubbing and dragging in the
Composition window on the external monitor. Interactive previews are always mirrored.
Renders: Each frame is shown the external monitor during a render. All renders are also mirrored.
You can toggle video output by pressing forward slash ‘/’ on the numeric keypad. This is a great
way to turn this handy feature on and off.

notes
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A Closer View
Need to get a better look at your Timeline? You can quickly
zoom in and out from the keyboard. Press = (equal sign) to
Zoom In. Press – (minus sign) to Zoom Out.
Need an even closer view of your Timeline? The tightest view
you can have is a frame level view. Why bother adjusting the
Zoom slider, or even tapping the = key multiple times when you
can toggle between a frame level view and your current zoom
level by tapping the ; (semicolon) key.

Back to Keyframes
You just finished previewing your comp and it looks great, except
for that one layer. A couple of quick tweaks to its keyframes
and it would be perfect. You’ll soon get tired of twirling down
through each effect just to get to your keyframes. The fast way
is to press U to toggle your Uber Animating Keyframes’ view.
Because we need all the help we can get, we think of this shortcut as U for User Keyframes.

The Fundamentals of Animation
There are five key components to animating a layer in After
Effects. Fortunately, Adobe put these properties at your fingertips.
Press A to Twirl down the Anchor Point.
Press P to Twirl down the Position.
Press R to Twirl down the Rotation.
Press S to Twirl down the Scale.
Press T to Twirl down the Opacity. (Think transparency.)
The following modifier keys also come in handy.
Hold down the Shift key to display additional properties after
selecting the first.
Hold down the Option key to display a property and add a keyframe at the Current Time Indicator.
On a PC, hold down Alt+Shift+ the shortcut letter (A, P, R, S or T) to achieve the same action.

Get Those Keyframes
Need to select multiple keyframes? Here are a few tips to make
it easier.
Select all keyframes associated with a property by clicking on
that property’s name in the timeline.
Add to that selection by Shift+Clicking on additional properties.
Lasso visible keyframes in the Timeline window.
Select all visible keyframes by pressing Cmd+Option+A
(Ctrl+Alt+A).
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Lost Your Way
If you’ve ever been zoomed in on your Timeline, you
know how easy it is to misplace the Current Time
Indicator. You could Zoom the Timeline back out to
find it, or scroll left or right as you search. But there’s an
easier way. (You knew we’d say that). Press D to scroll
your Timeline View to the Current Time Indicator.

Get on Top
Next time you need to work on a layer, try these two
shortcuts.
On the numeric keypad, type the number of the layer
you want to work with. For digits greater than 9, be
sure to type the numbers quickly with no gap.
Press X to Scroll the selected layer to the top of the
Timeline view.

What’s in a Name?
A layer can have two names, the one it comes in with,
and the one you give it. Why is this useful? It all boils
down to you keeping control. Perhaps you have added
a footage item five times into your composition. If
every layer was called Shot 1, you might get confused.
We would.
Step 1: Highlight the layer to rename it.
Step 2: Press Return (Enter).
Step 3: Type the new name.
Step 4: Press Return (Enter) to apply the name, or
click on another layer.
If you’d like to toggle between all of the Source
Names and the Layer Names, click the name field at
the top of the timeline.

Keys to the Locks
You are your own worst enemy, so protect your
comp. Want to avoid accidentally deleting or modifying a layer? Lock It! You can quickly lock a selected
layer by pressing Cmd+L (Ctrl+L). But what if you
change your mind? You can’t use the same shortcut
because locked layers cannot be selected. Here’s what
to do instead. Press Cmd+Shift+L (Ctrl+Shift+L) to
Unlock All Layers.

notes
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Make your Point (In- or Out-)
Need to move the in-point or out-point of a layer? No
problem. You can avoid numeric entry all together and harness the power of the keyboard.
Place the Current Time indicator at the desired time.
• To Set the Time In, press the [ (left bracket) key.
• To Set the Time Out, press the ] (right bracket) key.
Using this method, you can set either an in- or an outpoint, but not both.

Making Two Points (In- & Out-)
Want to set both your in- and out-points for a layer? This can easily be accomplished in the
Timeline Window.
Step 1: Place the Current Time indicator at the desired
time.
Step 2: To set the Time In, press the [ (left bracket) key.
This will move the in-point to the Current Time indicator. If
you’d like to trim earlier material, press Option+[ (Alt+[ ) to
Time Trim the in-point.
Step 3: Move the Current Time indicator to the desired
end time.
Step 4: To set the Time Trim for the out-point, press
Option+] (Alt+]).

Get Me Out (Or In)
Need to quickly move to the start (or end) of a layer? Press I to jump to the in-point of a layer, or O
to jump to the out-point. Remember though, if a layer starts or ends outside of your composition’s
time range, you won’t see the playhead (content) in After Effects.

Go Back to Start
Want to send multiple layers to line up at the beginning of your composition? Press Option+Home
(Alt+Home) to get selected layers to line up. Remember you can Shift+Click to select a range of
layers or Cmd+Click (Ctrl+Click) to select noncontiguous layers.

On Top of the Deck
While dragging layers around is often a valid option, it’s
not the fastest way to put a layer at the top of an 80–layer
composition, especially if it’s near the bottom. There are
several keyboard shortcuts that will come in handy.
• To bring a layer to the front, press Cmd+Shift+]
(Ctrl+Shift+]).
• To bring a layer to the back, press Cmd+Shift+[
(Ctrl+Shift+[).
• To move a layer one spot closer to the top, press Cmd+]
(Ctrl+]).
• To move a layer one spot farther back, press Cmd+[ (Ctrl+[).
10
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Pick a Layer, Any Layer
Want to quickly pick a layer to work with? Just type its
number on the numeric keypad. Type a single digit for
layers 1–9. For higher levels, type the layer number such
as 1 and 5 for 15.

Getting Around the Keys
Need to move between your keyframes? Press K to move
forward one keyframe. Press J to move back one keyframe. These shortcuts work with all visible keyframes,
not just those on the selected layer.

A Better Timeline
There are several Optional Panels available in the timeline. If you’d like to add or subtract headings, simply Control click on any column heading, and pick from the list. If you don’t like the column order, drag them left or right to new positions.

Get to the Modes
Want quick access to your mode switches? To toggle
between them, press F4. This shortcut works whether
or not the Timeline window is selected. If you’d like to
leave the modes out permanently, contextual click on the
Timeline columns, and choose Modes.

Making Blend Modes Easy
Part of the reason beginners pass on blending modes is
that they are hard to use if you don’t know which one
you want. Find an obscure list; scroll down (forever) only
to discover you need to pick a different one. There’s a much better way to experiment.
Highlight the layer or layers you want to blend.
Press Shift+= (Shift Plus Equal) to scroll through the list.
To move backward, press Shift+– (Shift Plus Minus) to return to a passed blending mode.

notes
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Incoming!
Finally, the left hand knows what the right hand is
doing. When you import a Photoshop file as a Comp,
all of its blending modes come in properly. Both
After Effects and Photoshop made some compromises. Photoshop CS adds the Hard Mix mode, while
After Effects modified its Color Burn, Color Dodge,
and Difference. The ‘old’ modes are still there in AE;
they are just preceded with the word Classic (in case
you weren’t feeling old enough already).

Outbound
So modes work on the way in, but if
you want to write a layered PSD file
out (Composition>Save Frame As>
Photoshop Layers), there are a few modes
that are not supported. After Effects will
substitute the closest equivalent if you’ve
used the following modes.
Dancing Dissolve >
Dissolve
Classic Color Burn >
Color Burn
Add		
>
Linear Dodge
Classic Color Dodge>
Color Dodge
Classic Difference >
Difference
Stencil Alpha
>
Not supported
Stencil Luma
>
Not supported
Silhouette Alpha >
Not supported
Silhouette Luma >
Not supported
Alpha Add
>
Not supported
Luminescent Premul >
Not supported

Want to keep in touch?
The Creative Cow website (http://www.
creativecow.net) offers several free forums and
tutorials. With a distinct slant towards video
professionals, the Photoshop/Illustrator forum
offers a great place to look for ideas or troubleshooting advice.

Copyright: ©2005 CMP Books
Acknowledgments: Marcus Geldud, Glen Stephens, Rachel Max.
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Contact Info: RHED Pixel - 703.734.7433
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