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Advanced After Effects & Photoshop Side by Side 
 
 When:  Thursday, September 2, 2004 - 2:30 - 3:30 p.m. 
Track: Motion Graphics 
 
Come learn insider secrets to getting the most from Photoshop and After Effects 
together. Learn elegant (yet accessible) techniques that'll wow your clients and look 
great on a television screen.  
 
 
 

Photoshop & After Effects 
 Simply put, Adobe Photoshop and After 
Effects are an excellent pair.  These two 
applications allow Motion Graphics and Video 
Editors to create great looking animations.  
Mastering Photoshop is an important step in 
mastering After Effects.  In fact, 80% of my After 
Effects work is completed in Photoshop.  With the 
introduction of Photoshop CS and After Effects 
6.5, a new level of interoperability is possible.   
 What you’ll find here are a series of tips 
on using these programs together.  These are 
excerpted from a new book called After Effects on 
the Spot (published by CMP Books).  Special  
thanks to Rachel Max and Marcus Geduld who 
tackled this challenging, yet fun, task with me. 
 
 

Get Your Toolbox Out 
Need access to your tools? To change tools on the fly without clicking (or even seeing) the 
Tools Palette, try these shortcuts:  

V Selection Tool  
W Rotation Tool 
C Toggles between Orbit Camera, Track XY 

Camera and Track Z Camera Tools 
H Hand Tool 
Z Zoom Tool 
Y Pan Behind Tool (Also works as Trim) 

Cmd+B 
Ctrl+B 

Cycles between Brush, Clone Stamp, and 
Eraser Tools 

Q Cycles between Rectangular and Elliptical 
Mask Tool 

Cmd+T 
Ctrl+T 

Cycles between Horizontal and Vertical Type 
Tools 

G Cycles between Pen, Add Vertex, Delete 
Vertex and Convert Vertex Tools 
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Speeding up the Comp Window 
Lowering the resolution of the Comp window can dramatically speed up previews. For 
example, switching from Full Resolution to Half Resolution speeds up previews four times 
(as it reduces both the width and height in half). In fact, previewing at half quality with the 
comp window set to 50 percent often provides a perfectly acceptable preview. To switch 
preview resolution quickly, use the following shortcuts. 

• For Full Resolution, press Cmd+J 
(Ctrl+J). 

• For Half Resolution, press 
Cmd+Shift+J (Ctrl+Shift+J). 

• For Quarter Resolution, press 
Cmd+Option+Shift+J 
(Ctrl+Alt+Shift+J). 

 
 
 

No Canvas 
If you are a Photoshop user, you might be more 
comfortable working with a transparency grid instead of a 
colored background. In the submenu of the Composition 
window, choose Transparency Grid to set the comp 
window to transparent. When you render the file, After 
Effects will fill the transparency with black. 
 
 
 

Build Your Own Room 
You’ve configured your windows perfectly. Every 
palette and the time controls are exactly where you 
want them. The timeline has just enough room. Now 
save that window arrangement. 

1. Choose Window>Workspace> Save 
Workspace.  

2. Name the workspace and click OK. 
3. It now appears at the top of your Workspace 

list. 
4. After modifying a workspace, save it again 

with the identical name, and when prompted, 
choose Yes to overwrite the old workspace. 

5. Workspaces are saved in, and become part of 
your user settings when you quit After 
Effects.  

6. To delete a workspace choose 
Window>Workspace>Delete Workspace. 
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Send it Out 
Mac users previously had the ability to 
preview their AE comps over Firewire or 
a video card, now with the release of AE 
6.5, PC users can too!  Plus Adobe has 
enhanced the ability of the preview all 
around.  It is possible to preview the 
contents of a Layer, Footage, or 
Composition window on an external video 
monitor.   
 
You can set Video Preview preferences by 
choosing After Effects > Preferences 
>Video Preview  (Edit > Preferences > 
Video Preview).  Choose one or more of 
the following interaction types. 
Previews: Both RAM preview and 
standard (spacebar) preview load on the 
external monitor. Choose Mirror on 
Computer Monitor to if you want to see the preview simultaneously on the computer screen 
and the external monitor, however mirroring reduces performance. 
Interactions: Interactive previews such as scrubbing and dragging in the 
Composition window on the external monitor. Interactive previews are always mirrored. 
Renders: Each frame is shown the external monitor during a render.  All renders are also 
mirrored. 
 
You can toggle video output by pressing forward slash ‘/’ on the numeric keypad. This is a 
great way to turn this handy feature on and off. 
 

 

Healthy Parent/Child Relationships 
There was once a time in AE where you had to precompose and/or nest layers to group 
them but no longer! A parent layer assigns its transformations (all except opacity) to its 
child layer. The child is still independent of the parent though, and can have its own 
animations applied. 

Think of it like your right arm (or left, if you prefer). Your fingers can wiggle on 
their own, yet they are parented to your hand. If the hand moves, the fingers move. 
Likewise, the hand is parented to the arm, if it were to swing outward, the hand (and 
fingers) would follow. And lastly, the arm is parented to your body. Where the body 
goes, the arm goes, and hence the hand, and likewise the fingers. One parent can control 
many layers but a child can only have one parent. 

If you don’t see a Parent 
Column in the timeline, 
contextual click on the top of 
any column and choose 
Columns>Parent. 

Use the Pickwhip to drag 
and select, or manually choose a 
parent by clicking on None. 

If you are assigning a 
parent to many layers, select multiple layers and select a parent for one of them. The 
parenting will be applied to all selected layers. 

Parenting can not be animated. If you want to stop parenting at any time, you 
need to split the layer, and assign None as a parent to the split. 
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The Fundamentals of Animation 
There are five key components to animating a layer in After Effects. 
Fortunately, Adobe put these properties at your fingertips. 

• Press A to Twirl down the Anchor Point. 
• Press P to Twirl down the Position. 
• Press R to Twirl down the Rotation. 
• Press S to Twirl down the Scale. 
• Press T to Twirl down the Opacity. (Think 

transparency.) 
 
The following modifier keys also come in handy. 

• Hold down the Shift key to display additional properties after selecting the 
first. 

• Hold down the Option key to display a property and add a keyframe at the 
Current Time Indicator. On a PC, hold down Alt+Shift+ the shortcut letter 
(A, P, R, S or T) to achieve the same action. 

 
 
 

Making your Point (In or Out) 
Need to move the in point or out point of a layer? 
No problem. You can avoid numeric entry all 
together and harness the power of the keyboard. 

1. Place the Current Time indicator at 
the desired time.  

2. To Set the Time In, press the [ (left 
bracket) key. Or, To Set the Time 
Out, press the ] (right bracket) key. 

Using this method, you can set either an in 
or an out point, but not both. 

 

Making Two Points (In and Out) 
Want to set both your in and out point s for a layer? This can 
easily be accomplished in the Timeline Window. 

1. Place the Current Time indicator at the desired 
time.  

2. To set the Time In, press the [ (left bracket) key. 
This will move the in-point to the Current Time 
indicator. If you’d like to trim earlier material, 
press Option+[ (Alt+[ ) to Time Trim the in 
point. 

3. Move the Current Time indicator to the desired 
end time. 

4. To set the Time Trim for the out point , press 
Option+] (Alt+]). 
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Boxes Inside of Boxes 
When you go on a trip, do you just throw 
everything into your suitcase? Your toothbrush 
and toothpaste in the same compartment with your 
swimsuit, running shoes, dress shirts? If you do, 
I’m sure you’ve had a few surprises after the 
gorillas have thrown your bags around a bit. The 
organized traveler uses several small bags and 
pouches to keep belongings intact and looking 
their best. The same holds true in After Effects. 

If your timeline has more than 20 layers, 
you should really consider organizing it better. 
Pre-composing allows you to take several layers 
and put them into a new composition. They still 
live in your timeline, but are far easier to manage 
and track. To Pre Compose, simply highlight the 
desired layers and press Shift+Cmd+C 
(Shift+Ctrl+C). 
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It’s OK, Be Shy 
Have a lot of layers in your timeline? Of course you do, you’re 
smart and talented enough to be reading this advanced book. 
Wouldn’t it be nice to make a little more room in your timeline 
to see things? Harness the Shy layers feature to dramatically cut 
down on vertical scrolling. 

1. To designate a layer as shy, click on the little 
“Kilroy” icon on each layer you want to hide.  

2. At the top of the timeline click the Shy (Kilroy) 
icon.  

3. All shy layers will disappear from the timeline 
view. They will, however, continue to affect 
the composition, and their results will show up 
in the Comp Window. 

4. At any time, you can reveal all shy layers by 
clicking on the Shy icon at the top of the 
timeline. 

Mighty Mouse 
Whether you run on a Mac or a PC, you need a 
two-button mouse with a scroll wheel to get the 
most out of After Effects 6.5.  Powerful 
navigation shortcuts are now at your fingertips. 

• The mouse wheel will scroll vertically in 
the Composition, Layer, or Footage 
Windows. 

• Hold the shift key to scroll horizontally in 
the Timeline and Project windows. 

• Hold the Option (Alt) key down to zoom 
around your mouse point in the 
Composition, Layer, or Footage windows.  
In the timeline, this shortcut lets you zoom 
in time. 

• The Option (Alt) key will also zoom you 
around a selected track or mask point. 

• You don’t have to have a window active, 
just hover over the window you want to 
pan, tilt, or zoom. 
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Point Text vs. Paragraph Text 
When wielding the Type tool, you can create a text layer 
in one of two ways. Either click in the Comp window (to 
create Point Text), or hold the left mouse button down 
and drag in the Comp window (to create Paragraph Text).  

Point Text treats each line you type as a separate 
block of text. New lines will only be created when your 
press the Return (Enter) key.  

Paragraph Text wraps text around to the next line 
when your type reaches the edge of the current line. The 
edge—the text’s bounding box— is defined by how far 
you dragged the mouse when you created the paragraph 
text layer. You can resize the bounding box (for 
Paragraph Text only) by selecting the text using the Text tool, clicking to place a cursor 
within the text, then dragging on one of the sizing handles around the perimeter of the 
bounding box. Shift-dragging a sizing handle will constrain the proportions of the 
bounding box. Make sure you don’t accidentally drag a sizing handle with the Selection 
tool, or you’ll scale the text, not its bounding box. 

 

The Kerning Shortcut 
Kerning means adjusting the spacing between 
pairs of letters. When font sizes are large, you’ll 
often notice that the space between some letters 
seems wider or narrower than the spaces between 
other letters.  

To even up the spacing, you can kern by 
placing your cursor between two letters, holding 
down the Option (Alt) key, then pressing the Left 
Arrow key to move the letters closer together or 

the Right Arrow key to move letters further apart. Since you can also use the Left and 
Right Arrow keys (without the Option or Alt key held down) to move the text cursor, you 
can quickly make many kerning adjustments by moving the cursor with the Arrow keys 
and adding in the Option (Alt) key when you want to kern. 
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Editing Photoshop Text       
in AE 
If you’ve imported a Photoshop Text layer 
into After Effects, you can edit its text without 
going back over to Photoshop. Select the 
layer, and choose Layer>Convert to Editable 
Text from the menu. This will only work with 
Photoshop Text layers—not flattened or 
rasterized layers. 

 

 

Web Geeks Rejoice! 
After Effects offers awesome text 
animation possibilities.  It also offers SWF 
output… however text was always 
rasterizes, which increased file size and 
prevented user scaling.  With the release of 
AE 6.5, text layers can now be exported as 
vectors when going to SWF. 

1. Choose File>Export>Macromedia 
Flash (SWF).  

2. Raster filters, motion blur and Fill 
Over Stroke are will still go out as 
rasterized type. 

 
 
 

Easy Typer 
Apparently the folks at Adobe noticed that a lot of customers 
were saying awfully nice things about Apple’s LiveType.   Sure 
AE’s text engine is as (or maybe more powerful).  But the folks 
at Apple sure had the usability thing down. 
Fortunately AE 6.5 does a shout back and tries to win this battle.  
You’ll find over 250 professionally-designed text animation 
presets.  These can streamline  the design process, but don’t 
replace it.  Presets can be used as a starting point, and then 
modified.  In fact you can save modified presets or your own 
creations and build up your library. 

1. You can view the available presets by calling up the 
Effects & Presets palette.  

2. To apply a text preset, just drag and drop it on top of a 
text layer in your Timeline or Comp window. 

3. You’ll find an extensive (and inspiring gallery) inside 
the After Effects 6.5 online Help. 
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Tap Out the Beat 
This is our favorite way to sync keyframes to an audio track. If you can tap your finger to 
the music, you can achieve better keyframing. 
 

1. Add a Solid Layer to hold your keyframes by pressing Cmd+Y (Ctrl+Y). Leave 
this layer selected. 

2. Set your preview area for the segment of audio you’d like to keyframe. 
3. Be certain the Audio button is highlighted in the Time Controls Window. 
4. Start the RAM preview. 
5. To add a Layer Marker, press the Multiply symbol (*) on the numeric keypad. 

Continue to tape out each audio event you’d like to sync to. When the Preview is 
finished, all of the Layer Markers will appear.  

6. To move between markers, use the J and K keys to move left or right respectively. 

Cool Transitions: Gradient Wipe 
Our favorite transition is the incredible Gradient Wipe. After Effects can use any gradient 
layer as a “transition map.” Create or modify a gradient in Photoshop first. You can 
combine gradient layers, blend modes, and filters to create an interesting map. 

1. Import the gradient map into After Effects. 
2. Add the gradient to your timeline but leave its visibility off. Make sure the 

gradient layer is the length of your composition. 
3. Apply the Gradient Wipe (Effect>Transition>Gradient Wipe) to the 

intended layer. 
4. Define the Gradient Layer source. 
5. Turn up the Transition’s softness for a smoother transition. 
6. Start the transition 100 percent complete, and then set a second keyframe 

to 0 percent where you want the transition to end.  
 

When you play back the comp, you’ll notice that the light areas on the gradient 
make certain corresponding pixels on the image 
layer vanish first; black areas cause other pixels to 
vanish last; gray pixels cause corresponding image 
pixels to vanish in the middle of the transition. 

Generally, you will need a stack of three 
layers in your Timeline when applying Gradient 
Wipe. You’ll need the two images (or videos) 
you’re transitioning between, and the gradient 
layer. It doesn’t matter where the gradient layer 
sits in the stacking order, because you’ll be turning 
its visibility off, but the other two layers should be 
stacked in order of what you want to see first and 
what you want to see second (first above second). 
Apply the gradient wipe to the first image. Don’t 
apply it to the gradient! 
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Mobile Style 
Layer Styles (formerly Layer Effects) do not like to travel. This is a common problem as 
there is not a single application out there that correctly interprets layer styles outside of 
Photoshop. 

In order to import successfully, you need to flatten them. Using a technique called 
Targeted Flattening, we can create a merged layer and preserve an editable layer within 
the same document. This gives you the best of  both worlds, proper imports, and room for 
future revisions. 

1. Save your document under a 
different name by using 
File>Save As. This is an extra 
precaution against accidentally 
deleting your work. (We usually 
rename it Document Name for 
AE.psd) 

2. Create a new (empty) layer and 
link it to the stylized layer that 
needs processing. 

3. Leave the empty layer 
highlighted. While holding 
down the Option key (Alt key), 
choose Merge Linked from the 
Layers Palette submenu. This 
merges the layers to the target 
layer, but leaves the originals 
behind. 

4. You should have a flattened copy on the target layer. Rename this 
flattened layer so you can easily locate it later. We recommend including 
the words FLAT in your layer name for ease of use. 

5. Repeat for all layers and save your work. This method will produce a 
layered document, which will import properly.  

Unsupported Styles 
If you want to import Photoshop layer styles, be aware of the 
following limitations. 
Unsupported Styles: 

o Gradient Overlay 
o Pattern Overlay 
o Stroke 
o Satin 

Styles that are Imported as Effects Comps: 
o Bevel 
o Inner Shadow 
o Inner Glow 
o Color Overlay 

Styles that create effect layers and animate intuitively: 
o Outer Glow 
o Drop Shadow 
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PS Alpha Channel (Multiple Layers) 
If you have a multi-layered Photoshop document, things are a little trickier. But creating an 
alpha channel is still an essential part of getting clean keying of graphics. 

1. Turn off the Visibility icon for 
all layers that are not part of 
the graphic you want to key. 

2. Create a new layer and 
highlight it. Hold down the 
Option key (Alt) and choose 
Merge Visible from the 
Layers palette submenu. A 
new layer is created from the 
existing layers. 

3. Cmd+Click (Ctrl+Click) on 
the layer’s thumbnail icon to make an active selection. Then turn the 
visibility icon off for the merged copy. 

4. Switch to the Channels palette and click on the Save Selection as Channel 
icon.  

5. Save your file as a PICT or TARGA with Alpha Channel using the 
previously described method. 
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Editing the Original 
Need to tweak the original file? Get ready for the 
best shortcut ever invented! 

1. Select a file either in the project 
window or timeline window 

2. Go to File>Edit Original or press 
Cmd+E (Ctrl+E) to open the file 
in its source program. The 
program will launch if not already 
open. This works particularl0y 
well for Adobe native 
applications. 

3. Tweak your file and save it 
4. AE should update the layer but if 

not choose it in the Project 
window and context click (right 
click or control click) and choose 
Reload Footage. Alternatively you can force AE to scan for changed 
footage by hitting Cmd+Option+L (Ctrl+Alt+L). 

If you are having trouble finding your footage in the project window, context-click on the 
layer in the timeline window and choose Reveal Layer Source in Project Window. 

Making Blend Modes 
Easy 
Part of the reason beginners pass on 
blending modes is that they are hard to 
use if you don’t know which one you 
want. Find an obscure list; scroll down 
(forever) only to discover you need to 
pick a different one. There’s a much 
better way to experiment. 

1. Highlight the layer or layers 
you want to blend. 

2. Press Shift+= (Shift Plus 
Equal) to scroll through the 
list. 

3. To move backward, press 
Shift+– (Shift Plus Minus) to 
return to a passed blending 
mode. 
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Be Consistent 
 Want consistent results?  Use templates.  After 
Effects comes with several built-in templates that addresses 
several of the more common production needs.   After 
Effects offers both render setting templates (for establishing 
quality, resolution, and duration) and output module (for 
defining file formats).  If these built-in options don’t do it 
for you however, you can easily create your own. 

1. Choose Edit > Templates> Render Settings… or 
Output Module…. 

2. Click New to create a new setting or Duplicate to modify a copy of an existing 
setting. 

3. Modify the settings to match your needs.  When finished click OK. 
4. If you’d like, you can choose one of your settings to be the default. 
 

 
 

The Most Important Email All Week 
After Effects 6 now supports scripts.  One of those 
scripts can actually render a file then email you upon 
completion.  If you’re a tech geek, the gears in your 
head are already spinning.  Most pagers and cell 
phones can receive text messages via the Internet.  
Just think, the leash has been cut! 

1. Open up your General Preferences and be 
sure that the Allow Scripts to Write Files 
and Access Network box is checked. 

2. Add your files to the Render Queue like 
normal. 

3. Choose File > Run Script > 
render_and_email.jsx, you will now be 
prompted for your email settings. 

4. Enter server smtp address: such as 
mail.mac.com, click OK 

5. Enter the reply to address: such as the email you want to use to send the message. 
6. If your server required log-in (most do), click YES and enter your ID and 

password. Click OK. 
7. Enter the recipients email address. Click OK 
8. An email with the subject AE Render complete will be sent when the queue is 

finished. 
How cool is that? 
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Want to keep in touch? 
The Creative Cow website 
(http://www.creativecow.net) offers 
several free forums and tutorials.  
With a distinct slant towards video 
professionals, the 
Photoshop/Illustrator forum offers a 
great place to look for ideas or 
troubleshooting advice. 
 

 

Instructor: Richard Harrington 
Richard Harrington is a certified 

Project Management Professional, Adobe 
Certified Expert in Photoshop and After 
Effects, and Apple-certified instructor in 
Final Cut Pro. Additionally, he has 
completed Avid's Master Editor 
Workshop and the Avid Certified 
Instructor Program.  

His visual communications 
consultancy, RHED Pixel, creates 
motion graphics and produces video 
and multimedia projects. He is a 
faculty member at The Art Institute of 
Washington, a popular speaker at 
conferences, and an instructor for 
Future Media 
Concepts.  

Richard is the author of Photoshop CS 
for Nonlinear Editors, and co-author of 
Final Cut Pro 4 On the Spot and After 
Effects On the Spot.  If you have more 
Photoshop questions, Richard is a 
moderator of Creative Cow’s Photoshop 
Forum. 

 
www.rhedpixel.com 
703.560.0220 
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