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Motion Control 3D
With RICHARD HARRINGTON
Richard Harrington is a certified Project Management Professional, Adobe Certified Expert and Instructor in
Photoshop and After Effects, and Apple-certified instructor in Final Cut Pro and Motion. Additionally, he has completed Avid’s Master Editor Workshop and the Avid Certified Instructor Program.
His visual communications company, RHED Pixel, creates motion graphics and produces video and multimedia
projects. He is a faculty member at The Art Institute of Washington, a popular speaker at conferences, and an
instructor for Future Media Concepts. He is the author of Photoshop CS for Nonlinear Editors and as well as a moderator Creative Cow’s Photoshop and Motion Forums.
Be sure to check out Rich’s websites for more resources:
• Photoshop for Video: http://www.photoshopforvideo.com
• RHED Pixel: http://www.RHEDPixel.com
• Motion Control 3D: http://www.motioncontrol3D.com

The Technique

z

“You know, like in that film… the one where the pictures move….”

Clients, Producers, and After Effects Artists alike have fallen
in love with bringing pictures to life. Whether it’s the simple
zoom or a more elaborate pan-and-scan, After Effects has always
provided an outstanding alternative to the traditional robotic or
operator controlled camera rig.
While the traditional art of motion control photography is one
I have immense respect for, I reserve the use of “real” cameras for
3D objects (such as an award show trophy) or complicated live
action effects shots. If it involves photos, computer interfaces,
or other graphics that are essentially (or initially) flat, then After
Effects is our weapon of choice.
At my shop, RHED Pixel, we have completed thousands of
hours of motion control through the years. Some has been for
independent documentary filmmakers; other effects have been
for Internet giants. The common thread between them is the
technique of Motion Control and Motion Control 3D. Both of
these rely heavily on a thorough understanding of image manipulation, composition, and cinematography. What I’m about to
show you has opened a lot of doors for us… I can’t teach you 15
years of collected knowledge in 15 or so pages (but I’ll sure try)
.

What You’ll Need

• A scanner capable of scanning at 1200 ppi optically (not
through interpolation).
• Client-provided photos (or use the ones in this chapter for
practice)
• Adobe Photoshop (6.0 or newer).
• Adobe After Effects (6.0 or later).
• A slide scanner is well suited to scan in negatives or 35mm
slides depending upon your client’s sources.
• A broadcast monitor to check for flicker.
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Essential Skills
Creating two-dimensional motion control is FAR
easier than its three-dimensional cousin. However, doing
either well is not for ‘newbies.’ To do these techniques well,
you must have a foundation in the following areas:
1.
Photo Restoration
2.
Color Correction
3.
Advanced Selections
4.
Layer Masking
5.
Cloning and Healing
6.
Pattern Making
7.
Organizing & Importing Layered Comps
8.
Using 3D Cameras
9.
Understanding 3D Space
10.
Cinematography

Choosing Images
In some cases, you won’t have a choice (that’s why clients
were invented). You’ll need to prep whatever photos they
want to use. But since they’ve likely hired you because of
your good judgment, sophisticated taste, and artistic abilities, you should have some input. Here are some general
guidelines to consider.
• Out of focus pictures are hard to look at and lower the
quality of the production.
• If the photos are cropped too tight or lack headroom,
you’ll need to add some back in. Folks often forget about
Safe Title constraints.
• Look for photos that have a sense of direction or action. Is
there “captured movement” within the shot? If so… go with
it.
•If you are going to perform 3D Motion Control, be sure to
identify a minimum of two planes. The best Motion Control
however will use three planes: foreground, subject, and
background.
•If working with existing digital files, ensure that they are
high resolution. Take your screen width (say 720) and multiply it by your zoom ration (say 5X) that will give you a total
pixel width minimum of 3,600 pixels.

notes


sponsored by

Motion Control 3D
With RICHARD HARRINGTON

Scanning Essentials
Whenever possible we prefer to do the scanning ourselves… not because it’s fun, but it’s the
best way to ensure you have what you need. Several problems can be introduced by those using
antiquated scanners with a distinct lack of skill. To get the best results, try the following:
• Before scanning an image, ensure you have the latest
software needed by your scanner. You can always check
their websites or use Version Tracker. Having problems
with a lack of support on the OSX side for older scanners (cough… Epson… cough… Nikon). I recommend
checking out VueScan from Hamrick Software.
• The most important thing when scanning is to be
consistent. Scan all of your photos in at one time if possible.
• Ensure that the scanner is lying flat, or you may get
misregistered scans.
• Use a gentle glass cleaner whenever smudges appear.
Spray the cleaner on the soft cloth, and then wipe the
scanner bed down.
• Make sure your photos are clean before scanning.
Never write on the back of photos, instead write on a post-it note and adhere to the back.
• Place your photos on the scanner straight. Use the edges to help you maintain parallel
edges on your photos. If you get crooked photos, try Photoshop CS’s newest automation tool
File>Automate>Crop and Straighten Photos.
• If your scanner allows you, set the white and black points before scanning. Think of this as a
white and black balance that you would do in a video camera. This will produce the best tonal
range. You can then use Photoshop’s color correction tools to adjust the white and black points as
well as make additional color changes.
• If you are scanning in previously printed items such as newspapers, magazines, books, inkjet
prints, etc, you will likely get a moiré pattern. Photoshop scanning the small spaces between the
previously printed dots causes this. Most scanners have a de-screen filter in their software. If
available use it when scanning previously printed items. If this is not available, run the Median
filter at a low value (Filter > Noise > Median).
• Scan at the quality you need. For video, scan so you have approximately 4,000 by 3,000 pixels.
This is generally enough pixel information to perform motion control in After Effects.
• Save to uncompressed formats such as TIFF, PICT or TARGA for maximum compatibility and disk
space usage. The PSD format is great for layered files, but is not as efficient for single layered files.
Always save the appropriate file extension for your file type.

notes
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Restoration Essentials
Photoshop has a wealth of touchup tools to prep images for the screen. If you aren’t very proficient, consider checking out Photoshop CS for Nonlinear Editors by me (like I wasn’t going to say
that). I also like Photoshop Restoration and Retouching by Katrin Eismann quite a bit. But since
we are both here together, let me share a few tips. Remember though, fixing photo damage is
not a step-by-step recipe. Practice is the easiest path to skill, but you can expect okay results right
away if you know which tools to use. With that in mind, I present some common scenarios and the
most likely solutions.

Holes and Tears
What’s essentially wrong is that you have areas of a
photo that contain no image data. The bottom line is you
need to replace the holes with good pixels. For small areas
like pushpin holes, you can easily use the Clone Stamp to
sample an adjacent pixels and paint in the hole
It is possible to just “finger-paint” the problem away.
Try using the Smudge Tool to push pixels around like they
are wet paint. Set the Smudge Tool to Darken, to push the
dark pixels into the hole.
Small tears are often fixed with the Healing Brush. But
if you have very large tears or holes, use the Clone Stamp
first (you can’t heal and area if it is a large patch of white
or black (or whatever color your scanner lid is). To avoid
repeating patterns, try cloning at a low opacity and sample
from different areas.

Goop and Gook
If there are physical blemishes
attached to the photo, check to see if
they can be wiped off and then rescan.
If not, then its time to turn to technology. You can use the Patch Tool to fill
an area. The easiest way is to take the
lasso tool and select the damaged area
(be sure to feather the selection for best
results). Then with the Patch Tool set
to Source Mode, drag the selection to
a clear area of similar texture. You may
want to hold the Shift key down to constrain movement to a straight line.
For dust or small blemishes, use the Smudge Tool. For dark spots on a lighter background,
smudge in the Lighten mode. For light spots on a dark background, smudge in the Darken mode.
Try to “follow the line” and look for natural folds or paths in the fabric or environment.
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Fixing Flicker
If the still image flickers on your broadcast
monitor, then you need to process it to remove the
extremely fine details that are causing the flicker.
Under Photoshop CS2, you’ll find a set of actions
called Video Actions in the Actions Palette preset
menu. Run the Interlace Flicker Removal action
on your pictures. Remember, if you have a deck or
Firewire device hooked up, you can choose File>
Export> Video Preview…. Not using CS2? Then try
running the Motion Blur filter (Filter>Blur>Motion
Blur) at a value of 1-4 pixels at an angle of 90˚.

Planning the Move
Just as a director storyboards their shots, you may want to block out your moves before moving into After Effects. You could always use your hands to form a Director’s viewfinder (but your
coworkers or client might think that’s silly).

2D
In Photoshop, select the Crop Tool. In the
options bar you can type in a new size. For a
standard video screen, type in 720 X 540 (which
will work for both NTSC and PAL). You can now
crop to a window shape and see your different
positions. Drag the crop box around or adjust
its size to modify the shot. When finished, click
Esc to exit the Crop Tool without applying the
crop.

3D
You’ll need to be a little more creative inside
your head (so slam a triple mocha or Red Bull
first). On a piece of paper or blank canvas,
create a staging diagram. Try to roughly determine how much separation there is between
your foreground, subject, and background.
The more distance (within believable reason)
the better depth of field and ability to harness parallax to create a sense of movement.
Parallax is the concept of “apparent motion” of
a nearby object against a distant background.
By increasing the distance between subject and
background, then moving the 3D camera, you
get a greater sense of photo-realistic motion.
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Final Preparations
It’s almost time to send the picture out to After Effects. Let’s just run through the few final
steps to ensure your photos are ready for animation. Traditional Motion Control in a 2D space will
not take as much prep work.

Color Correction
Be sure to check the following before importing into After Effects:
• Check the image’s white balance using an adjustment layer for Levels and the Set White Point
dropper in the Levels window.
• Adjust the contrast of the image within the Levels dialog box by moving the Black and Gray
slider of the Input Levels.
• It is easier to fix exposure on black and white images by working with a desaturated image, then
applying the sepia or duotone after tweaking exposure.
• Clamp the output levels in the Levels dialog to 16 and 235 to ensure broadcast safe.
• When satisfied, preview the image on your NTSC monitor. If all is well, flatten the image to apply
the color correction adjustment layer permanently.

Making Masks
If performing Motion Control 3D, you will
need to mask your images. This nondestructive technique is the best way to extract an
image. It is extremely flexible in that it supports multiple levels of transparency (via
shades of gray). Most importantly, you can
continue to touch up your mask throughout
the postproduction process. In After Effects
you can choose to Edit Original by pressing
Cmd+E (Ctrl+E) to switch back to Photoshop.
A little bit of paintwork and you can refine
problems in the layer’s transparency. When
done, you’ll just close and save and it will
update in After Effects.
1.
To add a mask, make sure it is a layer. You cannot mask the background of an image,
because it is not a layer. You must convert it to a layer by double-clicking, and naming the layer.
2.
Duplicate the layer two or three times so you have
enough copies for foreground, subject(s) and background.
3.
Make a rough selection using tools such as the
Polygonal Lasso or the Select> Color Range… command.
4.
With the selection active, click the Add Layer Mask
button at the bottom of the Layers Palette
5.
Use the Brush Tool with a soft edge to touch up the
layer mask. Be sure to load the default colors by pressing the
D key. White will be used for areas that are opaque (solid),
and black will be used for areas that are transparent. You can
now toggle between black and white by pressing the X key. A
good mnemonic for this short cut is Devil’s Xylophone.
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6.
Zoom in so you can
better see your pixels. Use the
Navigator to keep a ‘global’ view
and move around your canvas.
7.
Press [ for a smaller brush
and ] for a larger brush. To create a
harder or softer brush, use the Shift
key. Pressing Shift+[ will make the
brush softer, while Shift+] will form
harder edges.
8.
I suggest placing a highcontrast, solid color directly behind
the masked layer. This is a temporary step, but it makes it easier to
see stray pixels.
9.
Use the Smudge Tool
with Lighten or Darken mode to
touch up the layer mask. This is
a great way to move the mask in
only one direction while pushing. Adjust the Strength to taste; a
lower value usually works best.
10.
You can also use the Blur
Tool or a filter to slightly soften the edges for a believable feather. .
11.
If you need to “choke” a mask, try using a Levels adjustment directly to the layer mask.
By adjusting the midpoint, you can expand or contract the mask as needed.
12.
Leave the layer masks live for import into After Effects (don’t merge or flatten). This way
you can easily switch back via Edit Original for quick tweaks.
13.
As you create masks, remember you can load them by Cmd+Clicking (Ctrl+Clicking) on
the thumbnail. Once you’ve masked a layer, loading it, then inversing it (Select>Inverse) can be a
quick way to mask your remaining layers.

Filling in Holes
While the Foreground and subject will use masks, your background layer does not. Rather, you
must ‘remove’ all of the elements you extracted to their own layers (the foreground and subject).
To do this, you have several options.
• Clone Stamp
• Healing Brush
• Vanishing Point - Be sure to examine this new filter in CS2. It offers a way to move parts of a
photo via perspective cloning.
• Pattern Maker- This filter can create seamless patterns based on image data. This filter works
well for small patterns, but not on large objects. If the pixels in the sample lack contrast, increase
the Smoothness value to decrease edges. If the sample contains details that are being chopped
up, increase the Sample Detail value. Increasing the Smoothness and Sample Detail increases
render time. The Pattern Maker command is available only for 8-bit images. See the built in
Photoshop Help for detailed instructions.
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Preparing for Import
Here are a few essentials before sending
your images out to After Effects:
• I wish this went without saying, but
organize your layers in Photoshop. Every
layer needs a unique and descriptive
name that clearly identifies what the layer
is all about.
• Check your canvas size and ensure
that the width or height does not exceed
4,000 pixels. Unless you really need that
much of a zoom, going bigger can really
bog things down when RAM previewing
camera moves.
• Reduce the number of layers to only
the essentials.
• Leave a copy of the background layer
on top of your layer stack. This should
contain no masks and it will be used to
check composition later.
• Save all of your assets to one organized folder.

Moving to 		
After Effects
Getting your images into After Effects is easy.
You can double-click in the Project window
and navigate to your files. You can also drag
an entire folder in (provided there are no
nested folders within it). Select the folder, hold
down the Option (Alt) key and drag it into the
project window. If you need to rename the
folder, select it and press the Return (Enter)
key.
• If importing flat photos for 2D moves, just
bring the files in. Remember TIFF files are
more efficient than PSD for flattened images.
• If importing layered files, be sure to import
as a Composition (and do not crop the layers).
Keep the comp window set to quarter quality
to reduce your overhead.
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2D Motion Control Photography
Once your images are loaded, it’s a pretty straightforward process. There are however little
things that can make your motion control better than the competition.
1. Create a new composition that is sized for your edit system. Set the duration to match your
needs, plus add a little pad. After Effects will correctly interpret your Photoshop files as square
pixels. I recommend using the included presets for choosing the right composition settings. After
Effects will set everything except for the duration.
2. Drop a photo into your composition. Highlight the layer, and press S to call up the Scale
properties. Now hold down the Shift key and press A for anchor point and R for Rotation. The
anchor point is where the “camera” is pointing, and is a much better option than using Position.

3. Add keyframes for anchor point to set the initial ‘view’ of the photo. Jump to the end of the
comp by pressing the end key. Add your end keyframes.
4. If you will want to simulate a zoom, press S for Scale to access the scaling controls. Do not
enlarge your image beyond 100% for best results. You can also add Rotation keyframes (R), if
that is desired. If you own the Pro version of After Effects, I highly recommend using Exponential
Scale. In your timeline, click on the word Scale to highlight both keyframes. From the keyframe
assistants, choose Exponential Scale. This powerful assistant will accurately simulate the ballistics
of a camera zoom.
5. Use your animation assistants to
add Ease on the rotation and anchor
point key frames.
6. Double check that your quality
switches are all set to Best.
7. Add the comp to the Render
Queue and switch to the next shot.
8. When are your shots are ready,
batch render to your destination
folder.

notes
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Motion Control 3D
Creating movement within a picture is not for the faint of heart. If this is the first time using a 3D
camera in After Effects, your head might spin. I strongly encourage you to take a close (or even
refresher) look at Creating Motion Graphics by Trish and Chris Myer. Moving a camera is straight
forward, but there are a lot more things in play.

Build the Comp
This is perhaps the trickiest, and most important step. When you import your layered file, be sure
the layers stack up like this:
• Full Composite Image
• Foreground (with imported layer mask applied)
• Subject (with imported layer mask applied)
• Background
1. With the layered comp imported, you must switch its settings to match your editing standard.
Press Cmd+K (Ctrl+K) to call up the Composition Settings.
2. Promote all of the Layers to 3D space by clicking on the cube icon for each one in the Timeline.
3. Add a 3D Camera by choosing Layer>New>Camera. For now, stick with the default settings.
4. Turn off the visibility of the Composite Layer your top image.
5. Choose Window>
Workspace> Two Comp
Views. Make sure one is
set to Active Camera and
the second to either Top
or Custom View 1 (whichever you find easier). Make
Active Camera the active
window. Lower display
quality to half or quarter
depending on your processor speed and RAM.
6. Select your Background
layer (which should be number 5). Press P for position.
Adjust the Z slider to move
the image further away
from the camera (you may
use a positive number in
the range of 1,000 – 10,000
depending upon the ‘apparent’ distance in the original image. Then press S for Scale and scale
this layer up so it matches the original size. Turning the visibility for the composite image (layer 2)
off and on, or leaving it set to a low opacity for onion skinning, makes this easier.
7. Select your Subject layer (which should be layer 4). Repeat the Position and Scale steps, but do
not create as dramatic a separation between Foreground and subject. Use your composite image
(layer 2) for reference.
8. When satisfied, you can disable or delete the Composite image. It is for reference only when
setting up the shot.
10
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Add your Moves
Creating moves is much easier when using Two Comp View. In one viewer you can see through
the viewfinder, the other lets you see your physical camera.
1. Select the camera layer in the Timeline. You should notice your camera appear in the second
viewer.
2. Twirl down the transform properties. If experimenting… the easiest way is to add a keyframe
for all six properties. Either add those keyframes up front if you want to start with the initial composition, or towards the end if you want to finish there.
3. Move your current time indicator to a different position. In the second viewer, you will see your
physical camera. You may need to press Cmd+- (Ctrl+-) to zoom out and see all. Hold down the
space bar to move around the window by dragging.
4. Grab the green arrow to
move the camera on the
Y-Axis. Use the red arrow
to move along the X-axis
and the blue arrow to
move along the Z-axis.
5. You’ll also notice a line
with a small crosshair
circle. This is the Point of
Interest. Adjust this to
affect where the camera is
pointed.
6. Under the Options category, you can keyframe
Zoom and Focus Distance
(for zoom or rack focus
effects). You can also
adjust the aperture and
blur level to affect the
depth of field. Be sure
Depth of Field is turned
on for the most photorealistic results.
7. Avoid more than a 45˚ move or it will really fall apart. In fact, only subtle moves are needed to
get the most from this effect.
8. You can also use Ease to create realistic start and stop motions.
9. RAM Preview your results to get a sense of timing and composition. Initial preview should be
done at Quarter quality to expedite the experimental process.
10. Create traditional camera moves like dolly’s and pans to take advantage of the depth of field.
To really achieve parallax, be sure to introduce a slight angle to the movement (which is caused by
differences between camera position and point of interest).
11. When satisfied, add the comp to the Render Queue and switch to the next shot.
12. When are your shots are ready, batch render to your destination folder.

notes
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Now What?
Practice… Practice…
Practice. This is a fun way to
really add life to photos. You
can also get SIGNIFICANTLY
faster through repetition.
Motion Control, Image Prep
and Masking just gets easier
and better the more you do
it. Good luck and keep in
touch… for more developments, keep an eye on both
MotionControl3D.com and
PhotoshopForVideo.com

Want to keep
in touch?
The Creative Cow website
(http://www.creativecow.
net) offers several free
forums and tutorials. With
a distinct slant towards
video professionals, the
Photoshop/Illustrator forum
offers a great place to look
for ideas or troubleshooting
advice.

Copyright: ©2005 Motion Control 3D.com
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