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When the Web Isn’t the Web:
As the Internet becomes a bigger part of the professional 

world, so does your clients desire to display and promote 

their website in new ways. Imagine being able to take your 

audience “inside” a web page or computer interface. This 

also works if you need to create a high-end demo of a soft-

ware application in action. The ability to fly a virtual 3D cam-

era around through the action is very attractive. While it may 

not be as cool as Tron, it will impress your clients. Plus you’ll 

gain a healthy understanding of using 3D layers, and cam-

eras inside of After Effects.

Start Your Search Engines:
The first step is to acquire all of your web assets. You may 

have layered source files if it is a site you are developing, or 

you may need to perform screen captures. There are several 

different screen capture utilities available, two of the most 

popular include Snapz Pro for OSX and Snagit or Camtestia 

Studio for PC.

1. Set you monitor to its native resolution.  This is the reso-

lution at which the manufacturer prefers that the monitor 

runs, and be found in your user’s manual or online.

2. Change your desktop pattern to White for the 

screen captures.

3. Launch your web browser of choice, but simplify the inter-

face. This usually includes minimizing the number of but-

tons and things such as bookmark bars.

4. Set the browser’s point size larger (at least 16 points) and 

experiment with default font settings.

5. Capture elements, and if available, use the enlargement 

options of your capture software.

6. Save your captures as an uncompressed file format such 

as PICT or TIFF, or use a layered PSD file if needed.

7. Be sure to capture individual elements too such as cur-

sors, pop-up windows, and tools.
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Prep Your Files:
To save grief in the future, it is a good idea to try and build a very organized 

Photoshop document with layers.  This will serve as the basis for our work inside of After 

Effects.  While both programs are made by Adobe, there are a few gotchas in importing 

layered PSD files.

Layer Styles
Layer Styles will not come in cleanly.  It is a good 

idea to employ a targeted flattening approach to the 

individual styled layers.  

1. Always keep an original version with layer 

styles applied; instead prep a duplicate 

image for import.

2. Create a new empty layer.  

3. Link this layer to the one that had a layer style applied.

4. Select the stylized layer.

5. Choose Merge Linked from the Layers palette submenu.

Layer Sets
When you import a layered PSD file into After Effects, it 

treats layer sets in a special way.  An imported PSD file comes 

in as a composition, which is essentially all of your layers 

stacked in their original order with a Timeline.  Layer sets how-

ever come in as nested compositions within the larger compo-

sition.  This means you have to essentially ‘step inside’ a layer 

set to animate it.

• If you have a lot of layers to organize and you want to keep 

parts of the animation discreet use a layer set.  This is an easy 

way to animate pieces of your interface, but not have all of the 

layers at play at one time.

• If you need a lot of interaction between layers, do not use sets.

• If you are using layer sets as a non-destructive alternative to merging layers, don’t.  

Remember, you are should be working with a copy of your original layered file.  You can 

always open the original if you need access to a merged set.  Bringing in too many layers 

to After Effects only increases your project’s complexity and render times.

Naming
Keeping your After Effects Project organized starts with keeping your PSD file organized. 

The goal here is to prep content for animation, too many objects is like trying to juggle 50 

items simultaneously.  With that in mind, here’s some important production advice.

• Name every layer with a unique and descriptive name.

•  Keep layer names short, so you can preserve important Timeline real estate for impor-

tant things like keyframes and effects.

•  Unique layer naming is also very important for media management.  If a file is 

moved, you will often need to relink files.  Duplicate names can result in unintended 

relinking errors.
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Type Layers
Both Photoshop and After Effects 

have powerful type tools.  Under 

After Effects 6.5, you can even 

change Photoshop Type layers into 

After Effects Vector Type Layers 

(which can be animated and scaled).

•  You can select any live text on a 

web page and copy it to your com-

puter’s clipboard.

•  In Photoshop, you can paste that 

text into a text block and format it to taste.  Be sure to use a text block so the lines 

will wrap.

• Take advantage of Anti-aliasing in Photoshop for your type.

Major Cloning
As you break a web page or interface apart 

you will need to take advantage of cloning.  

Photoshop has several tools and techniques that 

can come in handy.

•  Duplicate in Place: Make a selection with any 

selection tool.  Then press Cmd+J (Ctrl+J) to 

create a copy on a new layer directly above 

the selection.

•  Dragging Clone: You can make quick clones by 

Option+Dragging (Alt+Dragging).  Just make a 

selection that you need to repeat with a selec-

tion tool.  Then hold down the Option (Alt) key 

and drag.

•  Clone and Heal: Both of these built-in tools will 

work well.  I generally clone to fill in an empty 

area and Heal to fill in a damaged area.

•  Free Transform:  A lazy, but effective way to fill in area of large color is free transform.  

Make a selection using the rectangular marquee tool, then press Cmd+T (Ctrl+T) to 

invoke Free Transform.  You can then drag to fill in with the color or simple pattern.

Non Squares Pixels
Those graphic professionals working in video have likely discovered the nemesis 

known as non-square pixels.  For years, it has been necessary to compensate for comput-

er graphics when video is the intended output.  This is because television screens often 

use a different pixel aspect ration than computer monitors.

Fortunately Photoshop CS has added support for non-square pixels.  With all of that 

said, DO NOT work with non-square pixels in Photoshop CS for this type of project.  We 

are going to be working with so many different sized sources, that it is easiest to tackle 

video output issues when we render.  After Effects is very astute with handling the unique 

requirements of video output.  We’ll tackle this issue later in our production workflow.
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Animation Time
With your assets prepped, its time to move into After Effects.  I will focus on some fea-

tures that are unique to After Effects 6.5, but much of these techniques will work in older 

versions as well.  The animation I am going to build is very elaborate; I recommend you 

start a bit simpler.  The files are available for you to explore... check the conference CD or 

http://www.rhedpixel.com/mainhandouts.html.  Also, I used Effect Essentials from Buena 

Software (http://www.buena.com).  The Camera Flash plug-in is free as part of the demo, 

and I used it in my final project.  Also, be sure to install the Cycore Effects on the After 

Effects 6.5 install disc.

Import
When you first launch After Effects, it’s a little underwhelming.  Be sure to create a new 

project right away.  

1. Choose File>New>

New Project.

2. Next Import your lay-

ered PSD by choosing 

File>Import File.  

3. In the dialog box, 

set Import Kind to 

Composition and 

Footage Dimensions to 

Layer Size.

4. Save your Project (repeat often).

5. To rename any objects or layers, press Return (Enter) to highlight the name.

Finish Your Page
There are a lot more things to add to finish out your animation.

1. Turn all of the layers on you want to use.  Check the 3D layer 

switch if you want the 3D camera to affect the object.

2. Select any imported text 

layers you want to animate 

character by character (or line 

by line).  Choose Layer> Convert 

to Editable Text.  Your font and 

kerning information will be pre-

served, but you can harness AE’s 

awesome text animation presets 

and properties.

3. Add any new text you need using AE’s 

built-in powerful text tools.

4. Add any other elements you need like cursors or logos.
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Making it Manageable
The file you imported is likely HUGE.  Be 

sure to keep the file size below 4,000 pixels, 

or your system memory will definitely be 

over-taxed.  

2. Pick the output format you need, 

such as NTSC DV (for DV or DVD 

output) or any multimedia size 

you need.  Use Square Pixels for 

Multimedia sizes (such as 800X600 

and Non-Square Pixels for TV or 

DVD output).

3. Your document will become 

cropped but all of your elements 

are still there.

4. Choose Window>Workspace> 

Two Comp Views.  This will give 

you a clear view from two angles.  

The first is what the camera is 

seeing; the other is a global view.  

Zoom out on your global comp 

view and expand the window 

until you see the outlines for 

all objects.

5. Use the Shy layer switch 

to mark layers to temporarily 

hide.  Then click the Hide all shy 

layers switch (looks like Kilroy).  

This is a good way to keep your 

Timeline simpler when you have 

lots of layers.

Make Your Edits
You’ll want to edit your layers down to get your timings right.

• Press [ to move the layer’s in-point  to your playhead

• Press ] to move the layer’s out-point  to your playhead

• Press Option+[ (Alt+[) to trim the layer’s in-point  to your playhead

• Press Option+] (Alt+]) to trim the layer’s out-point  to your playhead

• Press I to move to a layer’s in-point, press o for the out-point

• To go to a specific time, press Cmd+G (Ctrl+G) then enter the time.  Type in 

5:00 for five seconds, zero frames.  Video generally uses 29.97 frames per sec-

ond.  You can also use relative commands like +3:15 to move forward three 

and one-half seconds from your current time, or + - 3:15 to move backwards 

the same distance.
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Animate Your Text
Any live text layers in After Effects can be 

animated.  The easiest way is to use the presets 

as a starting point. On the sample project, I 

used Drop Bounce, Jetstream 2, Data Packet, 

and Data Stream.

1. Choose Help> Text Preset Gallery to pre-

view your choices

2. You can then access the presets from the 

Effects & Presets palette.

3. Drag the preset on to your text layer.

4. You can also dig deeper and build your 

own animations.  Explore AE’s built-in help to 

find out more about the animation options.

Animate Your Layers
• Layer Masks are an easy way to 

animate reveals.

• Be sure to turn stopwatches on 

to begin keyframing

• Transitions such as Gradient 

Wipe and Venetian Blinds 

are Helpful

• Helpful shortcuts include 

A- Anchor Point, P- Position, 

T- Opacity, S- Scale, R- Rotation.

Animate Your Cameras
•  Using the Two-Comp view is essential.  

One view allows you too see the camera 

(when you highlight the layer).  The other 

allows you to see through the lens.

•  You have an X, Y, and Z handle that you 

can grab and pull.  X moves horizontal-

ly, Y moves vertically, and Z is depth. Be 

sure to use stopwatches for keyframing.

•  You also have options under the 

camera for Zoom.

•  Be careful not to move the camera in too 

far, or you can move beyond the object.

•  Try using null objects and parenting to 

produce arc movements

•  You can use the Convert Vertex Tool in order to modify and smooth out the path.  

These paths are identical to the pen tool and Bezier tools in Photoshop and Illustrator.
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Polish the Edit
• Solids are simply Fill layers that can be useful in several ways, just choose 

Layer>New Solid and specify a size and color.

• A white solid set to Add mode can be used as a transition.  Just use opacity 

fades to create a blow out effect.

• A black solid can be used for fades to black.

• Solids can also be useful to create backgrounds.  By using the Particle Noise 

effect, you can create animated backgrounds.

• Add a music track, but stay away from MP3 files.

• Adjustment layers are a useful way to apply an effect to those layers directly 

below it...  Choose Layer>New Adjustment Layer.

Learn More
Using Cameras and 3D in After Effects is not easy, but it is doable. I recommend look-

ing at the following sources to learn more.

• Creating Motion Graphics volumes 1 & 2 by Trish and Chris Meyer

• After Effects on the Spot by Harrington, Max, and GeduldAfter Effects on the Spot by Harrington, Max, and GeduldAfter Effects on the Spot

• Creative After Effects 5.0, Animation, visual effects and motion graphics production 

for TV and video by Angie Taylor

Also be sure to check out Creative Cow for several good tutorials on using 3D cameras 

in After Effects

• http://www.creativecow.net/show.php?forumid=1&page=/articles/gerard_rick/

AEWeekly1/index.html

• http://www.creativecow.net/show.php?forumid=1&page=/articles/gerard_rick/

AEWeekly2/index.html

• http://www.creativecow.net/show.php?forumid=1&page=/articles/hansen_jay-

sen/shine/index.htm

• http://www.creativecow.net/show.php?forumid=1&page=/articles/sjostrom_

bjorn/3d_ride/index.html

• http://www.creativecow.net/show.php?forumid=1&page=/articles/dickinson_

john/video_wall/index.html

• http://www.creativecow.net/show.php?forumid=1&page=/articles/fischer_

john/video_wall/index.html

• http://www.creativecow.net/show.php?forumid=1&page=/articles/velez_dean/

animating_web/index.html

Want to keep in touch?
The Creative Cow website (http://www.

creativecow.net) offers several free forums 

and tutorials.  With a distinct slant towards 

video professionals, the Photoshop/

Illustrator forum offers a great place to look 

for ideas or troubleshooting advice.
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