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President, RHED Pixel

Richard Harrington is a certified Project Management Professional, Adobe Certified Expert in Photoshop
and After Effects, and Apple-certified instructor in Final Cut Pro. Additionally, he has completed Avid’s
Master Editor Workshop and the Avid Certified Instructor Program. His visual communications consul-
tancy, RHED Pixel, creates motion graphics and produces video and multimedia projects. He is a faculty
member at The Art Institute of Washington and American University, a popular speaker at conferences,
and an instructor for Future Media Concepts. He is the author of Photoshop CS for Nonlinear Editors and as well as a moder-
ator Creative Cow's Photoshop Forum. Richard is an accomplished video producer, having been named to AV Multimedia
Producer’s List of Top Producers for 2004 and winning a Cine Golden Eagle Award.

Video is a demanding business with lots of deadlines. notes
Photoshop’s automation tools are a HUGE timesaver 0,.,;, Pt
for video pros and they are pretty easy to utilize. There e 2
are three major categories of automation techniques: BT s
« Actions are pre-recorded or user created macros Flle nfo. il = T
that can play back several menu operations on Pgeseup..  0XP E::%{SE:T&:;.‘."..M
an image oy Tomp] MWE-Ruerormmo.
+ Automate commands perform complex tasks that preTo c Segiioa
@ are common for production. ;k"f}:ll;rl:(;;.l.’.m?.nklﬂ'nw... @

» The final category, Scripts allow you to perform
tasks that are more complex than actions. Scripts
are new to Photoshop CS and are beginning to make an impact on complex work-

flow issues.

Actions _

. . | History Actions ., Tool Presets (D
Virtually every command (and better yet, series of 7 gy Y
commands) can be captured and played back later. 7 b ik Blots
Basic actions will play back one command, such as v » Marble
a resize command or image mode change. In fact, v P Motz tapdt

. . v P Neon Rubber Bands
these simple actions often can take advantage of =
P Obsidian
your empty function keys on the keyboard. By com- ” M g
bining the Shift and Option (Alt) key modifiers, a 7 b Peychedeic Swings
standard keyboard has 48-60 customizable keys. ¥ g’ ¥ Rippled O
7 | [N P Make snapshot
v P Convert Mode
H = = ) E Make layer O
Consider creating actions for: 5
Reser Swatches v

« Applying an adjustment layer with output levels ' s Te el ol
set to 16 and 235 to make the image broadcast S
safe fro whites and blacks

* Running the De-Interlace filter

» Converting JPEGs to TIFFs or TARGAs
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But no one said Actions had to be basic:
« Check out Tools for Television’s Photoshop Toolbox for

COMPUTER

Tools

video-friendly actions

« Visit www.adobeevangelists.com for a very elegant
(and free!) solution called the Deflickerator (it's in the
Encore DVD section: http://www.adobeevangelists.com/
deflickerator.zip).

« For complex text and special effects, check out the
excellent site www.actionfx.com.

» Some of the first available packages came
from nik Multimedia. Be sure to check out m ﬁj:ﬁmﬁh@%
nik Efex! and nik Type Efex!

multimedia

Some Actions to Build
Here are a few of my favorite Actions. Try these out and see if they help you gain back
some time on your next deadline.

Safe Title Area (NTSC DV)
Step 1: Create a new document sized 720 X 534. Set the document to RGB mode.

Step 2: Choose Select All by pressing Cmd+A (Ctrl+A). Then, choose Edit>Fill and fill
with black.

Step 3: Create a new (empty) layer, and then name it Safe Area Overlay. You should
still have an active selection.

8 0o LalsTirle 1l @ 380% (AC1/8

Step 4: Scale the active selection to 90%
by choosing Select> Transform Selection,

and then typing in 90% in the Options bar
for width and height. Press Return (Enter).

Step 5: Load a red swatch as the foreground
color. Then choose Edit>Stroke and specify four
pixels centered. This is the action safe area.

Step 6: Choose Select All by pressing Cmd+A

(Ctrl+A), and scale the active selection to 80%
by choosing Select>Transform Selection.

Step 7: Type in 80% in the Options bar for width and height. Press Return (Enter).

Step 8: Choose Edit>Stroke and specify four pixels centered. This is the Safe Title Area.

Step 9: Lock the Safe Area Overlay layer by clicking on the Lock icon in the layer’s palette.

Step 10: Save your work.
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Flatten Layer Styles [iistory | Actions 0
Run this action on a layered PSD file for smoother ] w Flatten Styles B
import into most video editing and compositing Wi Make tayer
programs. Run this on a copy of the original docu- & ki i:j:\::mm"
ment in case you need to make changes. ‘Name: “Flattened”
Step 1: Create a new layer named Flattened. - S

3 . v w Link current layer
(It will be created by default right above Layers: layer "Flattened"
selected layer.) v Merge Layers v

Step 2: Press Option+[ (Alt+[) to select the layer S R

below to be flattened.
Step 3: Link to the layer named Flattened.
Step 4: Choose merge linked from the palette’s submenu.

Press STOP. (You can choose Option (Alt)+Merge Linked instead for targeted flattening).

Tips for Better Actions
* Brush strokes, cloning, and most manual tools from the toolbox do not work. There
are several alternatives, such as using a Gradient Fill layer instead of the Gradient tool.
« Set the Playback Options from the Actions palette submenu to play back an action
accelerated. Photoshop can process faster than it can redraw the screen.
* You can batch multiple folders at once. Create aliases or shortcuts within one folder
that point to the desired folders. Be sure to click the Include All Subfolders option.
« Back up your custom actions to two folders, the default location and a secondary
backup. This way, a reinstall or upgrade won’t blow your custom actions away.
« To create an action that will work on all files, you must record some commands with
the rulers set to percentage.
- Use File>Automate>Fit Image to resize images for a specific height or width.
* Photoshop will record the names of layers as you select them. This may cause play-
back issues, because the action will look for specific names. Use keyboard shortcuts to
select layers and such so that the action won't look for a specific name for that step.
o Choose layer above Option+] (Shift+Alt+])
o Choose layer below Option+[ (Alt+[)
o Choose top layer Shift+Option+] (Shift+Alt+])
o Choose bottom layer Shift+Option+[ (Shift+Alt+[)
o You can also arrange layers with shortcuts.
o These will move the current layer:
m Up the layer stack Cmd+] (Ctrl +])
m Down the layer stack Cmd-+[ (Ctrl +[)
m To the top Shift+Cmd-+] (Shift+Ctrl+])
m To the bottom Shift+Cmd+[ (Shift+Ctrl+[)

‘ ‘ Automation for Video Pros.indd 573 @

notes

573

1/18/05 3:32:35 PM ‘ ‘



Automation for Video Pros

BIHA]

CONFERENCE & EXPO

sponsored by

Adobe

With RICHARD HARRINGTON

Automate Commands

The Automate commands fall into two major categories: those that relate to actions
(Batch and Create Droplet) and Pre-built Production Commands.

Batch Processing

Photoshop allows you to run actions on an entire m
PDF Presentation...

folder of images. This can significantly cut down your
production time. =
. . Conditional Mode Change...

Step 1: To apply an action to several images, place Contact Sheet IL...
them into one folder. Crop and Straighten Photos
Step 2: Load the desired in the Actions palette. ;:t l'"_‘apge‘“ ——

. . ulti-Page to PSD...
Step 3: Choose File>Automate>Batch. Picture Package...
Step 4: Select the desired set and the action. Web Photo Gallery...
Step 5: Choose the folder to process in the Source
area. You may want to work with a duplicate copy so
that you don’t accidentally erase your images.
Step 6: Choose a destination folder for the new
images. Choose None to leave the files open or Save and Close to overwrite the

Create Droplet...

Photomerge...

penPalette 1.0...
T ———————————————

original images.
Step 7: Choose an error processing method: Stop for Errors or Log Errors to File.
Step 8: Click OK.

Droplets

A droplet is a Photoshop action conveniently stored as an icon
on your desktop. Files or folders can be dragged on top and | ;
batch processed. '
Step 1: Choose File>Automate>Create Droplet.

Step 2: Specify a location to save the droplet by using the LV TTESTOW
Save Droplet In section of the dialog box.

Step 3: Choose the specific set and action from the Set and Action menus. The action
you want to use must be currently loaded.

Step 4: Specify Play options for the droplet

Step 5: Decide if you want to include all subfolders to process files in subdirectories of
drag-and-drop.

Step 6: Select Suppress Color Profile Warnings to ignore color policy messages. These
can cause a batch to hang waiting for your input.

Step 7: Specify a destination for the batch-processed files in the Destination menu. .
Choose None to leave the files open or Save and Close to overwrite the original images.
You can also specify a folder to save the new images to as well.

Step 8: If choosing Folder, you must specify a file-naming convention for the batch-
processed files.

Step 9: Specify an error-processing option from the Errors pop-up menu. Log Errors
to File is generally best for batching.
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web Ga”ery - Web Photo Gallery

5: | Centered Frame 1 - Feedbac: ] € ox )
Need to get a bunch of images SE:':M, :ﬂme‘;dw :am = y o)
in front of your client for review? e »
Photoshop gives you several tem- (G oamury e R i v ;;_.:1"

plates to choose from for use in the

Web Photo Gallery command. If
you know HTML, or if you have a

Options: | Banner ™)

e Name: [American Diabeies ATsaciaion
web developer on staff, you can use EECOODERAIAL: [Richard Harringion
a customized style for pages that

feature your company logo

Contatt Info. |703-560-0220

Date: [1/31/04

and colors.

Step 1: Choose
File>Automate>Web Photo Gallery.
Step 2: Specify the site’s appearance:
Step 3: Under Folders, specify the
image source:

Step 4: Modify the banner options
with the rest of the site information that you

want displayed.

Step 5: Choose Large Images from the Options pop-up menu and specify how big the
display images should be.

Step 6: Next, modify the thumbnails from the Options pop-up menu.

Step 7: If you want, modify the colors for the page.

Step 8: You can add a watermark over each image (such as Confidential or For
Approval Purposes) by choosing Security from the Options pop-up menu.

When you run the automation, Photoshop will go into autopilot and begin build-
ing the site. In the destination folder, you will find an image’s subfolder, a thumbnail
subfolder, an htm subfolder, and an index page. The index page should be opened in
a standard browser to view the preview
site (or light box).

Automate >

Scripts » Export Layers To File
- - 7 = | Layer Comps To File
Scripting File Info... X%l 1| aver Comps To PDF
C . . S Layer Comps To WPG
Scripting in Photoshop offers a more |
: Page Setup... %P Riowee
powerful automation technology than Print with Preview... 3P |
Print... ®p |

actions. With scripts, you can choose
to perform more elaborate tasks than

Print One Copy X{O P

Jump To »

an action can perform. Photoshop CS
comes with four built-in scripts, all of
them designed to automate saving
multiple layers or layer comps off to
new files.

Writing scripts is far more challenging than actions. Actions use a GUI with obvious
controls (Play, Record, Stop). Scripting on the other hand requires you to use a scripting
language. On a Mac, you can use AppleScript or JavaScript. On a Windows box you can use
any scripting language that supports OLE automation, such as Visual Basic or JavaScript.

One script that is really handy is Export Layers to Files. This can be used to import a
layered file into a program that doesn’t recognize layers (such as Apple’s LiveType).
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Want to keep in touch?

The Creative Cow website (http://www.creativecow.net) offers several free forums and

tutorials. With a distinct slant towards video professionals, the Photoshop/Illustrator
forum offers a great

ann Loading "Creative Cow Forums™ place to look for ideas

—. el L i 2 ” . .
< (x| +]0) o - or troubleshooting

| [ Leaming Cemter Nadas-Live Digitsl Medis Designar image Lounge ey Apple Yahoo! Mac Amarsn Newsw

S adlvice.

SRAMACS IR VIZE. FAST 4 TeE WEE

IRl 1 ARTERATS L

Adobe ’hrn

Forum Cowmunity Leader(s) for Adobe Photoshop, llustrator m

24030

Jayse Richard
Hansen  Hariegton Macka«z-u SI-M

VIEW 2 works ol |

» ©i where can | find Neto CD label template Photoshop/lllustralor??
by Mark on Mar 23, 2004 at 18:06 gmt
« O Amanging a layer that won't go Io the botiom, by Brooke on Mar
23, 2004 at 17.56 gmt
by Brooke

o i
on Mar 23, 2004 at 20.38 gmt
+ 0 psd->llustrator by roberto on Mar 23, 2004 at 12:03 gmt
» i COW Articles: Book Reviews: Photoshop for Nonlinear
Editors by COW Articles on Mar 23, 2004 at 03:00 gmt
= Book review by MathDreamer on Mar 23, 2004 at 14:58 gmt
» Ra: Book raview by Richard Harringtan on Mar 23,
2004 at 15:50 gmt

DeckLink HD
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