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Gaining Speed
What you’ll find here are a series of
tips on gaining back valuable design time.
By changing your working habits, you can
learn how to preview and render faster. If
you are not using the latest version of AE,
you won’t be able to use all of these tips, but
most still apply. These tips are excerpted
from a new book called After Effects on the
Spot (published by CMP Books). Special
thanks to Rachel Max and Marcus Geduld
who tackled this challenging, yet fun, task
with me.

Be Consistent
Want consistent results? Use templates. After Effects comes with several built-in
templates that addresses several of the more common production needs. After Effects
offers both render setting templates (for establishing quality, resolution, and duration)
and output module (for defining file formats). If these built-in options don’t do it for you
however, you can easily create your own.
1. Choose Edit > Templates> Render
Settings… or Output Module….
2. Click New to create a new setting or
Duplicate to modify a copy of an existing
setting.
3. Modify the settings to match your needs.
When finished click OK.
4. If you’d like, you can choose one of your
settings to be the default.
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Changing Standards
Want to define the default standards for your
Render Settings or Output module? Sure you could
go all the way up to the Edit menu, but why bother
when you can set it in the render queue.
1. Be sure your current setting of choice is
saved as a template.
2. Hold down the Command (Control) key
as you select the preset name.
3. The default settings are now changed for
all future comps added to the render
queue.

Free Your RAM
Want to give AE more power to devote solely to your render? Try these tips to dedicate
your computer’s power.
• Choose Edit > Purge > All to release any RAM being held by previews or
cache files
• Close the Comp Window (unless you like watching paint dry). This will free
up more memory and computer resources for the render. The more layers you
have, the bigger benefit in closing this window.
• Quit any other applications running.
• Leave After Effects as the foreground
application (in other words if you need
to check email or play solitaire, use
another machine).
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Render Once, Output Many
A common misunderstanding about rendering is that many think you must render for
each output that you want. In other words if you need a movie at different
compressions and want an image sequence, you must render each separately,
Fortunately, this is FAR from true.
1. Highlight the required
sequence in the Render
Queue.
2. Choose Composition > Add
Output Module.
3. Modify the settings to suit
your needs.
4. Save the project.
5. Click Render when you are
ready to launch the Render
Queue.

Blurring and Blending Time
Many people are attracted to Frame Blending and Motion Blur. While its true that these
settings can generate smoother motion quality, they only do so in specific situations.
• Enable motion blur on a layer if you are animating
its position, rotation, scale, or anchor point
greatly. This will add realistic blur as the object
changes speed. Applying motion blur to slow
moving, or static objects has no visible effect
(except on your render times). Also, motion blur
has no impact for most effects if the motion is
created within an effect (such as the Offset or
Basic 3D effect). Notably, the Particle
Playground effect however is affected by Motion
Blur.
• Enable frame blending only if you have changed
the speed of a clip. It is most helpful on clips that
have been slowed down. However there are some
benefits on sped up clips as well. The point here
is that frame blending is useless unless there is a
speed change in the clip.

After Effects On the Spot, copyright CMP Books

In the Neighborhood
Part of render speed is determined by how
quickly your source files can be accessed.
Trying to read media files from a network or
an optical drive can significantly impact
render times. For best results, copy all source
files to the local machine. You should always
try to run media from internal drives or s
high-speed disk array.

Render SD and DV Simultaneously
Are you producing animations for multiple formats? Chances are likely that you’ll
often need both a DV and a Standard Definition output. Simple enough, right? Render
twice… if you like wasting time that is. A better way is to use two output modules.
1.)
Set your initial composition up at the larger size, such as 720 X 486.
2.)
Add the comp to the render queue and set the Render Settings. For best
results choose to Field Render with lower field first.
3.)
Next, set your output module for the first video and choose the settings
you need.
4.)
For the Digital Video render, add a second output module by choosing
Composition> Add Output Module.
5.)
Set this new output module for DV by choosing the QuickTime DV
NTSC 48kHz setting.
6.)
In the second output module, the one for DV, we need to remove six
lines of information. It is important to preserve field order. Click on
the Output Module name to open its settings.
7.)
Check the Crop box and specify to crop 2 lines from the top and 4 from
the bottom.
8.)
Name both output modules, be sure to clearly identify the DV render
with a unique name.
9.)
Close all open windows except for the render queue.
10.) Save your work.
11.) Click Render
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Need to Render Both Field Orders?
Need to render an animation for multiple video systems? Perhaps you need to create a
video file for use on older ABVB Avid systems (upper field first) and newer Meridienbased systems (lower field first). Field rendering is set in the Render Settings, not the
Output module.
Solution #1: Render twice.
Solution #2: Add a second Output Module. For the upper field first movie, enter +1 in
the Top field and –1 in the Bottom field.
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The Power to Adjust
Instead of running a blur or levels command on each layer of your composition, try
applying it to all layers simultaneously. One effect can often render faster than 5 effects.
The Adjustment layers work very well for global adjustments.
1.
Choose Layer > New > Adjustment
Layer.
2.
Apply any needed filter to the
Adjustment Layer
3.
All layers below will be affected.
4.
To modify the strength of the
adjustment, you can change the
Adjustment Layer’s opacity and blend
mode.

Get it Together
Oftentimes in the middle of a creative session, we get a little sloppy. We find ourselves
dragging files in, dumping things on the desktop, or even reading right from a network.
That’s fine when you are sitting in front of the machine, but we prefer our renders to be
autonomous. The best way to ensure a smooth render is to pull all files together into one
folder.
1. Choose File > Collect Files
2. Specify if you want files For All
Comps, For Selected Comps, or only
for Queued Comps.
3. When ready, click Collect.
4. The needed files will be copied to a
new folder that you specify. The
original files are still left behind.
5. You can choose to leave the original
files around (in case other projects or
users need them) or manually erase
them.
6. To find stray files, you can also run
the Collect Files Feature on the
original project, but this time generate
a report only.
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Where Do You Work?
Setting the Work Area is very important. It allows
you to define what portion of your composition is
loaded for RAM previews as well as define which
portion to render. You can set the Work Area by
dragging handles in the Timeline Window,
however there is a more precise method.
1. Position your Current Time Indicator at the
beginning of the Work Area and press B
(for Beginning).
2. Position your Current Time Indicator at the
end of the Work Area and press N (for
eNd).
Alternately, you can use your selected layers to
define the Work Area. Simply press Cmd +
Option + B (Ctrl + Alt + B) to set the Work Area
to selection.

The Most Important Email All Week
After Effects 6 now supports scripts. One of those scripts can actually render a file then
email you upon completion. If you’re a tech geek, the gears in your head are already
spinning. Most pagers and cell phones can receive text messages via the Internet. Just
think, the leash has been cut!
1. Open up your General Preferences and be
sure that the Allow Scripts to Write Files
and Access Network box is checked.
2. Add your files to the Render Queue like
normal.
3. Choose File > Run Script >
render_and_email.jsx, you will now be
prompted for your email settings.
4. Enter server smtp address: such as
mail.mac.com, click OK
5. Enter the reply to address: such as the email
you want to use to send the message.
6. If your server required log-in (most do),
click YES and enter your ID and password.
Click OK.
7. Enter the recipients email address. Click OK
8. An email with the subject AE Render complete will be sent when the queue is
finished.
How cool is that?
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Got Transparency?
Need to render your file so you can composite it in another application such as an editing
application? Be sure to choose a codec (compressor decompressor) that supports
embedded alpha channels. Many users will prefer the animation codec as it provides a
good balance of quality to size.
1. Click on the Output Module in the Render Queue
2. Choose Animation codec by clicking on the Format Options button and selecting
it from the next window.
3. While there specify Millions + colors. Click OK.
4. The Channels menu should now say RGB + ALPHA and depth set to Millions of
Colors +. If not, adjust them so they are properly set.
5. Your animation is likely pre-multiplied against Black so change it to set the color
to Straight (Unmatted).
6. Click OK and Render when ready.

Need to Re-render?
For one reason or another, it always happens, the need to re-render. Perhaps a small
tweak to a keyframe or a timing issue. Chances are while your animation may have
needed refining, the render queue was perfect. Save yourself some time and Re-Queue
that animation.
1. Select a previously
rendered
animation.
2. Press Command +
Shift + D (Control
+ Shift + D) to
duplicate the
render item with
the same settings
and output name.
This will rewrite
over the previous
file to the exact same destination.
3. Save your work, then click Render when ready to output.
After Effects On the Spot, copyright CMP Books

More RAM Previews
By now you’ve probably noticed that the
importance of RAM previews. There is the
standard one which you normally see in the Time
Control Palette and can be invoked by pressing 0
on the numeric keypad.
The other RAM Preview controls can be
accessed by click on the words “RAM Preview
Options.” This preview is usually a lower quality
method, but can be configured to the user’s
preference. To launch this alternate preview, Shift
+ click on the Preview button or press Shift + 0 on
the numeric keypad.

A Better Stop
Normally when you click Stop on an item in the
render queue, it adds it to the bottom of the list and will
pick up where it left off. That may be what you want, but
often you intended to bust the render, tweak it, and rerender. To stop a render and re-queue it to begin at the
beginning, hold down the Option (Alt) key when clicking
Stop Render. This will avoid the pickup and add the item
to be re-rendered from the start of the original output
settings.

Network, O’ Network
In theory network rendering is great, if you own AE Pro
you can use multiple machines to get your project
rendered faster. In practice the After Effects team could
learn a thing or two by looking at more advanced
Network Rendering engines (such as Shake). With that
said, if you have multiple machines in your office (even a
WiFi network or an Ethernet Crossover cable for two
machines will work) you should try network rendering
out. On the AE install disc you must install the Render
Client onto other machines.
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If DV is the Place to Be…
Need to output a QuickTime movie from AE for use in a DV based editing system
(DV/DVCAM/DVCPRO)? Use the following settings when designing for NTSC DV
video.

Render Settings
Quality
Resolution
Field Render
Frame Rare

Best
Full
Lower Field First
29.97

Output Template
Format
Format Options/Codec
Quality
Channels
Depth
Color
Audio
Size
Channels

QuickTime Movie
DV/DVCPRO – NTSC
Best
RGB
Millions of Colors
Pre-multiplied
48.000 kHz
16 Bit
Stereo
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How to Gang Up a Render
It is possible to set up a render farm to render a single composition. The trick is that you
have to write an Image Sequence. Here’s how to pull it off:
1.
Install the AE render engine on all the machines that will participate in
network rendering. Make sure that any needed plug-ins or fonts are also
installed on those machines.
2.
You must create a watch folder on
one of the systems (better yet a
server) that can be seen by all
others. You should name it AE
Watch Folder.
3.
On each node of the render farm
you need to set the watch folder
by choosing File>Watch Folder.
4.
Create your project; add items to
the render queue, set up render
settings and output modules. Be
sure to write an image sequence, not a movie file.
5.
You should now ensure that all the source files are pulled together. Use
the collect Files feature (File > Collect Files) to move a copy to the Watch
Folder. You must make sure that all items in the Render Queue have
output names before collecting files. Then select Enable Watch Folder
Render. You will also want to select the Change Render Output To option
so the output directory is mapped to the watch folder.
6.
Make sure that all items are set to Skip Existing Files (it’s a Render
Settings option). This way the render nodes will skip existing frames and
go to the next.
7.
You can monitor the progress through a web browser (sophisticated we
agree). After Effects will generate HTML pages and place them in the
Watch folder. Navigate to that folder and open the HTML page. You can
click refresh to update the page periodically.
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After Thoughts
After Effects offers you a powerful feature called Post-Render Actions. These allow you
to choose from a list of pre-defined actions that you’d like to happen after the file is
rendered.
1.
Choose Composition>Pre-render or flip down the triangle next to the Output
Module of an existing item in the render queue.
2.
Choose one of the following Post-Render Actions
• None – Does Nothing (the default)
• Import – Adds the rendered file into the project window when rendering
is complete
• Import & Replace Usage – Imports the file into the project and replaces
usage for specified items. You determine which files will be replaced via
the pickwhip. We find this most useful to replace precompositions that
appear in multiple comps (such as the motion background in a group of
show bumpers).
• Set Proxy – Allows you to use the rendered file as a proxy for a specified
project item (again use the pickwhip). This will speed up previews.
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Instructor: Richard Harrington
Richard Harrington is a certified Project Management
Professional, Adobe Certified Expert in Photoshop and After
Effects, and Apple-certified instructor in Final Cut Pro.
Additionally, he has completed Avid's Master Editor
Workshop and the Avid Certified Instructor Program. His
visual communications consultancy, RHED Pixel, creates
motion graphics and produces video and multimedia projects.
He is a faculty member at The Art Institute of Washington, a
popular speaker at conferences, and an instructor for Future
Media Concepts. He is the author of Photoshop for Nonlinear
Editors and as well as a moderator Creative Cow’s Photoshop
Forum.
Richard can be reached at http://www.rhedpixel.com
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